Drywall Talk - Professional Drywall and Finishing Contractors Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hey! I just bought a 31.5” marshal pro skim blade. I am making a flat ceiling. I rolled the mud on with a 30mm sleeve but when I go to smooth it out it’s missing spots and giving me skips.

I’m using synko lite line. I tried keeping the mud close to as trick as our of the box as well as tried thinning it down some and still getting skips.

Not to sure if this is just normal or not.

Anyone have an experience with this or know what’s going on here?



Grey Twig Wood Beige Tints and shades
Jaw Gesture Paint Art Liquid
 

·
Registered
Joined
·
22 Posts
First picture looks like you may have laid the blade too flat and left mud. Second one looks like there was not enough mud to carry the blade across the surface, and hollows were left behind.
Is you're skim blade a rigid, steel blade? Other than that, stuff happens and you overlooked it until it dried. You'll develop an eye for defect in your work the more you skim, and you'll know to add a bit of mud and wipe it again. It'll never be perfect tho, no matter how good you get. Ode to the touch up gods
 

·
Master Mud Monkey
Joined
·
252 Posts
I think you got the angle wrong lol, the blade bends a bit with pressure and the shape of the handle bends it just right so it makes a good even pressure. Sorry you probably just need to practice a bit more. Use a light when you glaze if you can so it's easier to notice any bad sport you need to run the blade over with again.
 
1 - 5 of 5 Posts
Top